use strict;
my $str = '>>> string_1 = \'variety.com/2017/biz/news/tax-march-donald-trump-protest-1202031487/\'
>>> string_2 = \'variety.com/2017/biz/the/life/of/madam/green/news/tax-march-donald-trump-protest-1202031487/\'
>>> string_3 = \'variety.com/2017/biz/the/life/of/news/tax-march-donald-trump-protest-1202031487/the/days/of/our/lives\'
Desire';
my $regex = qr/(?:(?!/)[\S])*-(?:(?!/)[\S])*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}