$re = '/(?:(?!/)[\S])*-(?:(?!/)[\S])*/m';
$str = '>>> string_1 = \'variety.com/2017/biz/news/tax-march-donald-trump-protest-1202031487/\'
>>> string_2 = \'variety.com/2017/biz/the/life/of/madam/green/news/tax-march-donald-trump-protest-1202031487/\'
>>> string_3 = \'variety.com/2017/biz/the/life/of/news/tax-march-donald-trump-protest-1202031487/the/days/of/our/lives\'
Desire';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);