const regex = /^\s+|\s+$|\s+(?=\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s+|\\s+$|\\s+(?=\\s)', 'gm')
const str = ` the man in the land ofo `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);