#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\$cdt\[([a-zA-Z_][a-zA-Z0-9_]{3,100}),([a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500}),([a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500}),?([a-zA-Z0-9_\- ]{1,100}=[a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500}(?:;[a-zA-Z0-9_\- ]{1,100}=[a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500})*)?]$"
Local $sString = "$cdt[cdt1,$[col1]-4==1,$[col2]+$[col3],var1=1;var2=2+1;var3=6==6]" & @CRLF & _
"$cdt[cdt1,$[col1]-4==1,$[col2]+$[col3]]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")