Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
"
^\$cdt\[([a-zA-Z_][a-zA-Z0-9_]{3,100}),([a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500}),([a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500}),?([a-zA-Z0-9_\- ]{1,100}=[a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500}(?:;[a-zA-Z0-9_\- ]{1,100}=[a-zA-Z0-9_+\-*/%&|^!=<>\[\]$ ]{1,500})*)?]$
"
gm
Input 1
1
New
$cdt[cdt1,$[col1]-4==1,$[col2]+$[col3],var1=1;var2=2+1;var3=6==6] $cdt[cdt1,$[col1]-4==1,$[col2]+$[col3]]