const regex = new RegExp(';(?=[^[]*])', 'gm')
const str = `["Text1;Text2;....;TextN"];asjkdjksd;ajksdjksad["Text1;Text2;....;TextN"]
.["Text1;Text2"]...long text...["Text1;Text2;Text3"]....long text...["Text1;...;TextN"]...long text...
I ONLY want to change the ";" in the ["Text1;...;TextN"]`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);