#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(long|anyword)\b\K[- ](?=(?:(?1))\b)"
Local $sString = "Sample text:" & @CRLF & _
"test text long long test text" & @CRLF & _
"test text long long long long long long test text" & @CRLF & _
"test text long long test test long long long test text" & @CRLF & _
"" & @CRLF & _
"How it should be:" & @CRLF & _
"test text long-long test text" & @CRLF & _
"test text long-long-long-long-long-long test text" & @CRLF & _
"test text long-long test test long-long-long test text" & @CRLF & _
"" & @CRLF & _
"How does it work now:" & @CRLF & _
"test text long-long test text" & @CRLF & _
"test text long-long long-long long-long test text" & @CRLF & _
"test text long-long test test long-long long test text"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)