# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\d\s*){10}(?:(?:\d\s*){3})?"
test_str = ("2442141411\n"
"One 2 442141411 two 24 42141411 three\n"
"2 44214141 1\n"
" 2 6 9 32 2 3 8 376 67\n"
"2 6 9 32 2 3 87 77 67 8\n"
"2 6 9 32 2 3 8 37667\n"
"2442141411 123\n"
"2442141411 1\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.