package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\pL\s]+$|u`)
var str = `Marcelo á é í ó ú`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}