using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"process name:\s+(?<process_name>[^ ]+)";
string input = @"<30>1 2023-12-13T06:22:20.197Z 10.205.101.94 4 CGA3001I [sev=""INFO"" msg=""Event"" event=""Data is getting from process name: C:\\ProgramFiles\\notepad.exe. Now we can try to write the logs. Mode: Operational""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}