re = /}(.|\n)*?}/
str = 'adsasdassdasdfff }
qualquer texto, com arumentos escapados como á â , . A B C 0 9 [ ] \\n ; ~ ^ - = \' " !@#$%¨¨&**( e quebra de linha
}
asdasdasasdsa
eeeee
{
aaaaaa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end