#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(ge\-[0-9]{1,2}\/[0-9]{1,2}\/[0-9]{1,2}([\.]?[0-9]{1,2})?)(\s+)(\w*)(\s*)(\w+(\-)?\w+)(\s*)(\w+(\-)?\w+$)?"
Local $sString = "--- JUNOS 20.4R1.12 Kernel 32-bit JNPR-11.0-20201028.e1cef1d_buil" & @CRLF & _
"" & @CRLF & _
"{master:0}" & @CRLF & _
"adminl2j@child-ex2300-24t> " & @CRLF & _
" dollar, euro, pound" & @CRLF & _
"{master:0}" & @CRLF & _
"adminl2j@child-ex2300-24t> show interfaces ge-0/0/0 terse " & @CRLF & _
"Interface Admin Link Proto Local Remote" & @CRLF & _
"ge-0/0/0 up AdminPort-Down " & @CRLF & _
"ge-1/1/1 uP HighStatus eth-switch" & @CRLF & _
"ge-0/0/88.12 uP High-Status eth-switch" & @CRLF & _
"ge-0/0/22 uP High-Status eth-switch" & @CRLF & _
"" & @CRLF & _
"ge-20/11/0.0 up up protocol3" & @CRLF & _
"" & @CRLF & _
"{master:0}" & @CRLF & _
"adminl2j@child-ex2300-24t> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")