use strict;
my $str = 'Password_pass
PASSWORD_123
Password123
Password_123
Password_123
Password_1233
Password_12333
Password__123
Password___123
Password#123
Password~123
Password?[]123
Pa_1234
Pa_12345
Pa_0123456789012345678901234567890123456789012345678901234567890
Pa_01234567890123456789012345678901234567890123456789012345678901';
my $regex = qr/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[~@#^*\-_+\[{}\]:./?])(?!.*(.)(\1\1))[\w~@#^*\-_+\[{}\]:./?!]{8,64}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}