re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[~@#^*\-_+\[{}\]:.\/?])(?!.*(.)(\1\1))[\w~@#^*\-_+\[{}\]:.\/?!]{8,64}$/m
str = 'Password_pass
PASSWORD_123
Password123
Password_123
Password_123
Password_1233
Password_12333
Password__123
Password___123
Password#123
Password~123
Password?[]123
Pa_1234
Pa_12345
Pa_0123456789012345678901234567890123456789012345678901234567890
Pa_01234567890123456789012345678901234567890123456789012345678901'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end