import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-9]{9,15}|(?=[a-zA-Z]*[0-9])(?=[0-9]*[a-zA-Z])[A-Za-z0-9]{6,15})$";
final String string = "123456789\n"
+ "12345678Y\n"
+ "Y234Y2\n"
+ "Should not be valid:\n\n"
+ "12345678\n"
+ "123X4\n"
+ "ABCDEFGHYJ\n\n"
+ " - Contains between 9 and 15 numbers (Only numbers)\n"
+ " - Contains between 6 and 15 numbers+letters (it must contain both, numbers and letters. Only letters is not a valid option).\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}