re = /^(?:[0-9]{9,15}|(?=[a-zA-Z]*[0-9])(?=[0-9]*[a-zA-Z])[A-Za-z0-9]{6,15})$/m
str = '123456789
12345678Y
Y234Y2
Should not be valid:
12345678
123X4
ABCDEFGHYJ
- Contains between 9 and 15 numbers (Only numbers)
- Contains between 6 and 15 numbers+letters (it must contain both, numbers and letters. Only letters is not a valid option).
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end