using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Pet=)\w+";
string input = @"Owner=John Pet=Dog City=NY
Owner=Steve Pet=Cat City=LA
Owner=Paul Pet=Hamster City=LS";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}