const regex = /(?<=Pet=)\w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Pet=)\\w+', 'gm')
const str = `Owner=John Pet=Dog City=NY
Owner=Steve Pet=Cat City=LA
Owner=Paul Pet=Hamster City=LS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}