using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<full_tag><\s*+(?<name>[^\s>]++)[^>]*+>(?>[^<>]++|(?&full_tag))*+</\s*+\g{name}\s*+>)(*SKIP)(*F)|<\s*+(?<bad_tag>[^\s>]++)[^>]*+>[^<>]++";
string input = @"<p>hgfgff</p>
<p>ffdffd</h2>
<p>zsfdffd</h6>
<p>hgfgff</p>
<p>hgfgff<h1><b>text</b><u>text</u></h1></p>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}