use strict;
my $str = '<p>hgfgff</p>
<p>ffdffd</h2>
<p>zsfdffd</h6>
<p>hgfgff</p>
<p>hgfgff<h1><b>text</b><u>text</u></h1></p>
';
my $regex = qr~(?<full_tag><\s*+(?<name>[^\s>]++)[^>]*+>(?>[^<>]++|(?&full_tag))*+</\s*+\g{name}\s*+>)(*SKIP)(*F)|<\s*+(?<bad_tag>[^\s>]++)[^>]*+>[^<>]++~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}