import Foundation
let pattern = #"(?<full_tag><\s*+(?<name>[^\s>]++)[^>]*+>(?>[^<>]++|(?&full_tag))*+</\s*+\g{name}\s*+>)(*SKIP)(*F)|<\s*+(?<bad_tag>[^\s>]++)[^>]*+>[^<>]++"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p>hgfgff</p>
<p>ffdffd</h2>
<p>zsfdffd</h6>
<p>hgfgff</p>
<p>hgfgff<h1><b>text</b><u>text</u></h1></p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)