#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<ns2:([^<]*?) xmlns:ns2|<faultstring>([^<]*?)<\/faultstring>"
Local $sString = "<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"><env:Header/><env:Body><env:Fault><faultcode>env:Server</faultcode><faultstring>List "Outage List2" already exists.</faultstring><detail><ns1:ListAlreadyExistsFault xmlns:ns1="http://service.admin.ws.five9.com/"><listName xmlns:ns2="http://service.admin.ws.five9.com/">Outage List2</listName><message>List "Outage List2" already exists.</message></ns1:ListAlreadyExistsFault></detail></env:Fault></env:Body></env:Envelope>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")