import re
regex = re.compile(r"""
# ./configure parser
^(?:
(?:configuring[[:space:]]for[[:space:]](.+))
|
(?:
checking[[:space:]]
(?:
(?:build|host)
[[:space:]]system[[:space:]]type
|
how[[:space:]]to[[:space:]](.+?)
|
for[[:space:]](.+?)
|
whether[[:space:]](?:to[[:space:]])?(.+?)
)[\.]{3}
)
(?:
[[:space:]]+
(?:
$
|
(?:
(yes)
|
(no)
|
(?<!^)(.*)(?=$|\n)
)
)
)?.*
)$
# ^(?:(?:configuring[[:space:]]for[[:space:]](.+))|(?:checking[[:space:]](?:(?:build|host)[[:space:]]system[[:space:]]type|how[[:space:]]to[[:space:]](.+?)|for[[:space:]](.+?)|whether[[:space:]](?:to[[:space:]])?(.+?))[\.]{3})(?:[[:space:]]+(?:$|(?:(yes)|(no)|(?<!^)(.*)(?=$|\n))))?.*)$
""", flags=re.MULTILINE | re.VERBOSE | re.IGNORECASE)
test_str = ("configuring for zsh 5.7.1-test-2\n"
"checking build system type... x86_64-apple-darwin17.7.0\n"
"checking host system type... x86_64-apple-darwin17.7.0\n"
"checking for gcc... gcc\n"
"checking whether the C compiler works... yes\n"
"checking for C compiler default output file name... a.out\n"
"checking for suffix of executables... \n"
"checking whether we are cross compiling... no\n"
"checking for suffix of object files... o\n"
"checking whether we are using the GNU C compiler... yes\n"
"checking whether gcc accepts -g... yes\n"
"checking for gcc option to accept ISO C89... none needed\n"
"checking for special C compiler options needed for large files... no\n"
"checking for _FILE_OFFSET_BITS value needed for large files... no\n"
"checking how to run the C preprocessor... gcc -E\n"
"checking for an ANSI C-conforming const... yes\n"
"checking for gcc option to accept ANSI C... \n"
"checking whether to use prototypes... yes\n"
"checking for grep that handles long lines and -e... /usr/local/bin/ggrep\n"
"checking for egrep... /usr/local/bin/ggrep -E\n"
"checking for ANSI C header files... yes\n"
"checking for sys/types.h... yes\n"
"checking for sys/stat.h... yes\n"
"checking for stdlib.h... yes\n"
"checking for string.h... yes\n"
"checking for memory.h... yes\n"
"checking for strings.h... yes\n"
"checking for inttypes.h... yes\n"
"checking for stdint.h... yes\n"
"checking for unistd.h... yes\n"
"checking for size_t... yes\n"
"checking for working alloca.h... yes")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")