re = /(?|(date .+)|title .+|whatever.+)/
str = '+++
date = 2020-09-08T16:18:51+02:00
title = "Lire le cycle de l\'Assassin Royal, c\'est compliqué"
tags = ["livre"]
copy = "https://twitter.com/jpcaruana/status/1303356472705921026"
really_any_key_I_want = "any value"
+++'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end