package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:in a|in the|in) ?(.+?) ?(?:area|section)`)
var str = `Then there should be 3 elements in the article list section
Then there should be 3 article preview elements in the article list section
Then there should be 3 article preview elements in the article list section in the article section`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}