import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:in a|in the|in) ?(.+?) ?(?:area|section)";
final String string = "Then there should be 3 elements in the article list section\n"
+ "Then there should be 3 article preview elements in the article list section\n"
+ "Then there should be 3 article preview elements in the article list section in the article section";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}