# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:.*Location1.*?q=(\d+),(\d+))?.*$/\1|/gm;t' <<< "Text A Location1 More text q=1,2)\" Even more text
Text B
Text C Location1 More text q=3,4)\" Even more text
Text D"