const regex = /^(?:.*Location1.*?q=(\d+),(\d+))?.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.*Location1.*?q=(\\d+),(\\d+))?.*$', 'gm')
const str = `Text A Location1 More text q=1,2)" Even more text
Text B
Text C Location1 More text q=3,4)" Even more text
Text D`;
const subst = `\1|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);