#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/www.google.com\/(?:\S*)!1s(\S+)!3"
Local $sString = "https://www.google.com/maps/api/js/ReviewsService.LoadWriteWidget?key=AIzaSyBcv0QfUNUfBwo8pIGJ3teNCkaluSGUWus&authuser=0&pb=!2m1!1sChIJmQ0yuZ-gToYRJySW6BCQc6M!3shttps%3A%2F%2Fwww.google.com!5sen&cb=99146092"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")