Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[\w-\.]+@([\w-]+\.)+[\w-]{2,4}$
/
gm
Input 1
1
New
kaibrahima32@gmail.com pape@g