const regex = /\s*(Name):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Agent):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Status):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Resource Type):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Resource):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Poll interval):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Batch size):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Condition):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Pattern):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(Name):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\\/\\\\]+)\\s*(Agent):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\\/\\\\]+)\\s*(Status):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\\/\\\\]+)\\s*(Resource Type):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\\/\\\\]+)\\s*(Resource):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\\/\\\\]+)\\s*(Poll interval):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\\/\\\\]+)\\s*(Batch size):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\\/\\\\]+)\\s*(Condition):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\\/\\\\]+)\\s*(Pattern):\\s*([\\w\\s!@#$&():<>*=\\-`.+,\\\/\\\\]+)', 'gm')
const str = ` Name: MONITOR1 Agent: AGENT_QM_1 Status: Started Resource Type: Directory Resource: C:\\inputfiles Poll interval: 1 minutes Batch size: 2 Condition: File Size (>= 1B) Pattern: *.txt (wildcard)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}