// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*(Name):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Agent):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Status):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Resource Type):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Resource):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Poll interval):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Batch size):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Condition):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Pattern):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)").unwrap();
let string = " Name: MONITOR1 Agent: AGENT_QM_1 Status: Started Resource Type: Directory Resource: C:\\inputfiles Poll interval: 1 minutes Batch size: 2 Condition: File Size (>= 1B) Pattern: *.txt (wildcard)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}