import Foundation
let pattern = ##"\s*(Name):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Agent):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Status):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Resource Type):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Resource):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Poll interval):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Batch size):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Condition):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)\s*(Pattern):\s*([\w\s!@#$&():<>*=\-`.+,\/\\]+)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" Name: MONITOR1 Agent: AGENT_QM_1 Status: Started Resource Type: Directory Resource: C:\inputfiles Poll interval: 1 minutes Batch size: 2 Condition: File Size (>= 1B) Pattern: *.txt (wildcard)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)