#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\G(?!^),|DATA\.tracking\.user = \{)\s+([^:]+): (\d+|"[^"]*")"
Local $sString = "DATA.tracking.user = { " & @CRLF & _
" age: "19", " & @CRLF & _
" name: "John doe" " & @CRLF & _
"} // This does not works" & @CRLF & _
"" & @CRLF & _
"DATA.tracking.user = { age: "19", name: "John doe" } // This works" & @CRLF & _
"" & @CRLF & _
"DATA.tracking.user = { " & @CRLF & _
" age: "19", " & @CRLF & _
" name: "John doe" " & @CRLF & _
"} // This does not works"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")