import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/[^\\/]+\\.(?!com|fr|org\\b)[a-zA-Z]{2,}";
final String string = "va sur https://rcut.in/sa\n"
+ "https://izi.su/blabla\n"
+ "https://sn.ms/blabla\n"
+ "https://abn.ac/lol\n"
+ "https://fetuj.sk/mdr\n"
+ "https://cutl.top/1fHnl\n"
+ "https://www.google.fr\n"
+ "je suis pas un test\n"
+ "https://manger.fr\n"
+ "https://app.mobile.fr\n"
+ "https://www.hop.fyi/chPsF \n"
+ "www.google.com\n"
+ "https://voici.org\n"
+ "https://www.20minutes.fr/societe/4052202-20230909-choisi-avoir-chien-enfant-temoignage-veterinaire-helene-gateau \n"
+ "http://url.actualite.fr/89afe2c1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}