const regex = /https?:\/\/[^\/]+\.(?!com|fr|org\b)[a-zA-Z]{2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/[^\\\/]+\\.(?!com|fr|org\\b)[a-zA-Z]{2,}', 'gm')
const str = `va sur https://rcut.in/sa
https://izi.su/blabla
https://sn.ms/blabla
https://abn.ac/lol
https://fetuj.sk/mdr
https://cutl.top/1fHnl
https://www.google.fr
je suis pas un test
https://manger.fr
https://app.mobile.fr
https://www.hop.fyi/chPsF
www.google.com
https://voici.org
https://www.20minutes.fr/societe/4052202-20230909-choisi-avoir-chien-enfant-temoignage-veterinaire-helene-gateau
http://url.actualite.fr/89afe2c1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}