package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([a-z]+\s+[a-z]\d+(?:,\d+)+)\s*(\S+)\s*([\d:\s]+\d)\s*([^\/]+)\s+\/\s+([^\/]+)\s+\/\s+([^\/]+)\s+$`)
var str = `DER V3,0,0,3323 Xkisjd 2014 02 25 05:23 PGM / RUN BY / DATE
VER V1,2,4,0003 MfgHJd 2015 12 11 11:13 PGM / RUN BY / DATE `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}