import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z]+(?:\\s[a-zA-Z]+)*$";
final String string = "Válid Full Name:\n"
+ "David Gilmour\n\n"
+ "Juan Munoz\n\n"
+ "Claudio Alberto da Silva\n"
+ "Invalid Full Name:\n"
+ "David Gilm01ur Jr.\n\n"
+ "Juan Muñoz\n\n"
+ "Cláudio Alberto da Silva";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}