#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*define\(\s*(['"])([^\1]+)\1\s*,\s*(['"])([^\3]*)\3\s*\);"
Local $sString = "define('DB_HOST', 'test');"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")