const regex = /\s*define\(\s*(['"])([^\1]+)\1\s*,\s*(['"])([^\3]*)\3\s*\);/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*define\\(\\s*([\'"])([^\\1]+)\\1\\s*,\\s*([\'"])([^\\3]*)\\3\\s*\\);', '')
const str = `define('DB_HOST', 'test');`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}