import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([<\\w\\-]+(?:=)?(?:\"|')?[\\w\\-]+(?:\"|')?)";
final String string = "<meta charset=\"utf-8\" alone foo=\"tab\"/>\n\n"
+ "<meta charset2=\"utf-8\"foo2=\"tab\"/>\n\n"
+ "<meta charset3=\"utf-8\"alone2 foo3=\"tab unclosed/>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}