import re
regex = re.compile(r"([<\w\-]+(?:=)?(?:\"|')?[\w\-]+(?:\"|')?)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("<meta charset=\"utf-8\" alone foo=\"tab\"/>\n\n"
"<meta charset2=\"utf-8\"foo2=\"tab\"/>\n\n"
"<meta charset3=\"utf-8\"alone2 foo3=\"tab unclosed/>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")