#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https:(.*?)\/track\/(.*?)\?(.*)"
Local $sString = "https://open.spotify.com/track/7cy1bEJV6FCtDaYpsk8aG6?si=4NrCtBYRRt6QIEggvr5-UQ" & @CRLF & _
"https://open.spotify.com/track/2mKS9ECgxNSRQgmQO7CY8x?si=70ua2XGPTvy5tg3tAfSIHQ" & @CRLF & _
"https://open.spotify.com/track/1rqqCSm0Qe4I9rUvWncaom?si=j8IHrLXASjmgSOc77seefQ" & @CRLF & _
"https://open.spotify.com/track/7MRY4VpCuZvBmFda6ZCk2G?si=BIlDAq22RkSb559U3Ymdgw" & @CRLF & _
"https://open.spotify.com/track/1yG1OpMiV8WtDeOYEBvNW8?si=VSOSzYHCQGW7-DZoDTq15A" & @CRLF & _
"https://open.spotify.com/track/0zYkf4pCiGAhEp5Z3iUkml?si=DQ0o-GGRQfmqABxDcqeywQ" & @CRLF & _
"https://open.spotify.com/track/4HCcvFdHfwR2u3WPPPVRv6?si=N_l1p_fMTXSYdEA2V4uKKg" & @CRLF & _
"https://open.spotify.com/track/6A3ff44rkAsNUPq5ZpG0Lw?si=X6E_z8ClSm-gqOh_PNJ8aA" & @CRLF & _
"https://open.spotify.com/track/1owidcBLuyqbtlJRWyRubJ?si=AfuGmcQ4RL6znQrBnHNsUQ" & @CRLF & _
"https://open.spotify.com/track/72OeMxh65OcA6riQ7fRH6c?si=jXksouMoTTy9gHiusgAN3Q" & @CRLF & _
"https://open.spotify.com/track/1PqZRvgKb2OepsA7aeb64y?si=n7RCpDM_TOeAsSSgJqecCQ" & @CRLF & _
"https://open.spotify.com/track/4K8pmNLIAhetFRpEBGV0dJ?si=O_Vwez-xQ-ufDqeSjJmYjw" & @CRLF & _
"https://open.spotify.com/track/3DVNUiBeYKbp7JvvcrfqZB?si=vRTYM_lXRP--LwoFg44M8Q" & @CRLF & _
"https://open.spotify.com/track/4w2iAP3X4FkpPb5kjRdIDx?si=w0PH7da9RgeWspRVYrFeFw" & @CRLF & _
"https://open.spotify.com/track/0Y2QWrhPh6ATyaWYT0QLIR?si=hwnF_-1aTcioBOSJLHNE1w" & @CRLF & _
"https://open.spotify.com/track/4pkZNPC6yeMnQABwkTmsR6?si=JC6rPKnBQRCGF6NP9I6QKg" & @CRLF & _
"https://open.spotify.com/track/5rR1C059TESZuNiiYEzZBa?si=-ncveFyxS3KDa7Yf54opZg" & @CRLF & _
"https://open.spotify.com/track/6aFc0W6xVS9kN9E9NGekAl?si=9Jiu-bANSuaPPjJOE_b5GQ" & @CRLF & _
"https://open.spotify.com/track/6ZF6PsmadIgyuxp0wqD9qO?si=HardRQQzSXGMxiscNsuuIQ" & @CRLF & _
"https://open.spotify.com/track/7HhawuOJ17618C4VJfJn2K?si=Ve0FWw02SDuhA3FO9ZRfVA" & @CRLF & _
"https://open.spotify.com/track/2ZFAzZ5uluMR8TeO6YEy52?si=QYw76ZYDTAqmigwp-4K0_w" & @CRLF & _
"https://open.spotify.com/track/7IO8jHHbV9P4VtcfeGvEZy?si=xp4fWYXVQP-NBhjF6M6LkQ" & @CRLF & _
"https://open.spotify.com/track/0CLYfCWlqR1zB6Wqi6VTwy?si=_yiWBH82SUmNfKrcoUFSXw" & @CRLF & _
"https://open.spotify.com/track/4PAT0WuPzHOn94bP0BYZUz?si=oPcZRxB0TYGbjzvz54ZkPw" & @CRLF & _
"https://open.spotify.com/track/5XKDliIGPTUnNRwRZsd0oN?si=okAtielaT2ChEL2vK3DV8Q" & @CRLF & _
"https://open.spotify.com/track/5fpj84RsT9cOTfWUCxBTXu?si=5He0nt3oQzSipKrtwaKJ-A"
Local $sSubst = "spotify:track:$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)