const regex = /<textarea[^>]+data-match-this="[^"]+"[^>]*>.*?<\/textarea>/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<textarea[^>]+data-match-this="[^"]+"[^>]*>.*?<\\\/textarea>', 'gms')
const str = `<textarea data-match-this="true">{{one}}{{two}}</textarea>
<textarea>{{three}}{{four}}</textarea>
<textarea data-match-this="true">
{{five}}
{{six}}{{seven}}
</textarea>
<textarea>
{{eight}}
{{nine}}{{ten}}
</textarea>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}