using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:Sunscreen|Lubricant)\h+[^()]*\((\d+)\h+Quantity\)";
string input = @"Sunscreen 25g (200 Quantity)
Lubricant 100ml (50 Quantity)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}