$re = '`\b(?:Sunscreen|Lubricant)\h+[^()]*\((\d+)\h+Quantity\)`m';
$str = 'Sunscreen 25g (200 Quantity)
Lubricant 100ml (50 Quantity)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);