package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]+(?:\.[0-9]+)+`)
var str = `get_a_string_A14_for_1.23.87.19_A12_and_others
get_a_string_A14_for_1.23.827.19_A12_and_others
get_a_string_A14_for_1.23.87.1_A12_and_others
get_a_string_A14_for_2.23.87.19_A12_and_others`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}