using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=&)m=[^ ]*\&p=[^& ]*";
string input = @"index.html?cr=33&m=prod&p=ded";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}