$re = '/^.{4}(?:^|\n|\\\\n)(#+\s+.*)/s';
$str = 'abcd
## My Title\\nxyz';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);