import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\ ?){1,}[._\\-\\w]{1,25}\\@[\\-\\w]{1,25}(\\.[\\-\\w]{1,25}){1,3}?([\\ ]{1,}?)?$";
final String string = " emanuel_on@catracalivre.com.br ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}